Directly contact our Support Team

Identity verification warnings related to Bitdefender security agents for Windows

After September 17, 2018, when using or trying to install older versions of Bitdefender security agent for Windows, you may receive some errors and warnings about identity trust (see the pictures below), and the operating system may prevent you from installing the kit. This issue occurs because the kit you are trying to use is old and the security certificate used to sign it is no longer valid.

  
Fig. 1. Warning occurring at local installation, or repair/uninstall via Control Panel    Fig. 2. Warning occurring when trying to fix issues via Windows Security Center (Action Center)

 

Learn how this issue affects the Bitdefender product versions, and what you can do to address the situation, from the details described herein.

 

 

Bitdefender Endpoint Security Tools (BEST)

 

Version Lost functionalities Remediation
6.2.x Any type of deployment or local installation of these kit versions For GravityZone on-premises editions
Download and publish the latest kit versions:
  • BEST 6.6.4.71, for Windows 7 and later; Windows Server 2008 R2 and later
  • BEST Legacy 6.4.2.79, for older Windows operating systems
For GravityZone cloud editions
The latest kit versions are already available in GravityZone Control Center.
Fix issues via Windows Security Center / Action Center. This means you cannot use this method to update signatures, enable Antimalware or Firewall. Update the agent to latest version:
  • BEST 6.6.4.71+, for Windows 7 or later; Windows Server 2008 R2 or later
  • BEST Legacy 6.4.2.79+, for older Windows operating systems
Repair or uninstall run via Control Panel or Start Menu.
note Note:
On Windows 7, they work if you turn off UAC.
6.4.x The following installation methods:
  • Any type of deployment through a Relay
  • Local installation through Windows Downloader
note Note:
Please note that BEST for Windows Legacy does not support repair and remote deployment.
You can install the agent locally using the full kit.
6.6.1.36 - 6.6.4.68 The following installation methods:
  • Any type of deployment through a Relay
  • Remote deployment through Install task from GravityZone Control Center
  • Installation through Windows Downloader

For GravityZone on-premises editions
Download and publish the latest kit version (6.6.4.71+).

 

For GravityZone cloud editions
The latest kit version is already available in GravityZone Control Center.

 

You can install the agent locally using the full kit.

Repair run via Control Panel or Start Menu, if the kit published in GravityZone is one of these versions. This issue persists even if the agent updated to the latest version (via task or policy).

 

Endpoint Security by Bitdefender

 

important Important:
Endpoint Security by Bitdefender has reached end of life (EOL) as of June 30, 2018. Upgrade to the latest versions of Bitdefender Endpoint Security Tools at your earliest convenience.

 

Version Lost functionalities Remediation
5.1.4.223 - 5.3.36.793 Local installation with full kit or setup downloader. Upgrade to the latest versions of Bitdefender Endpoint Security Tools:
  • BEST 6.6.4.71+, for Windows 7 and later; Windows Server 2008 R2 and later
  • BEST Legacy 6.4.2.79+, for older Windows operating systems
Repair or uninstall run via Control Panel.
note Note:
On Windows 7, they work if you turn off UAC.
Fix issues via Windows Security Center / Action Center. This means you cannot use this method to update signatures, enable Antimalware or Firewall.
5.3.36.796 - 5.3.37.798 Repair or uninstall run via Control Panel, only if initially installed using kit version 5.3.36.793 or older.
note Note:
On Windows 7, they work if you turn off UAC.

 

Bitdefender Tools for Windows

 

Version Lost functionalities Remediation
All Remote deployment via GravityZone Control Center. Install locally using the SYSTEM user.

Rate this article:

Submit